Instructions for configuring Wazo 19.17 via web GUI?

I previously installed Wazo 18.03 using the web UI and know how to do that.

But it does not appear that the sequence or actual steps for using web UI in Wazo 19.17 can be deduced from what worked in 18.03.

The instructions I can find for configuring Wazo 19.17 all appear to use API calls and I would like to stay with configuring via the web UI.

Are there instructions for how to create a (simple) system using the web UI for 19.17? If so, I’ll use them and extend as needed, but I ned to get started somehow.

If anyone is interested, once I have the extended instructions documented for my purposes, I can share with the community.

Hi @Ramblin

You’re right, it can be difficult to migrate forward 18.03. As we explain in this blog post, the wazo-platform project is now a toolkit configurable with API.
There is still an available interface that you can install via apt install wazo-ui. But for now, we do not plan to release official documentation with this interface as screenshot and scenarios.

We will leave it to you (the community) to share and proudly expose your scenarios and use cases :slight_smile:

I will gladly share my documentation after I have it working.

But at this point, I cannot get past getting InCall and Outcall to work. See
where I have been working with Sebastian ( @sduthil ) to try and get InCall and OutCall to work.

I have:

  • The system installed
  • Devices (Aastra phones) hooked up
  • A softphone hooked up
  • Three trunks from 2 different providers hooked up

I can:

  • Make calls inside the LAN no problem. Between devices and Device to Softphone and reverse
  • Have all three trunks register with their respective provider, as confirmed with ‘asterisk -rx “pjsip show registrations”’
  • See inboud calls get to the server, as confirmed with 'asterisk -r", but not be processed according to the InCall routing setup; I just get busy signals. (Logs show in Link above)
  • See the OutCall routing poperly trigger the dialplan as confirmed by ‘asterisk -rx “dialplan show {external_number}@{internal_context}”’ , but the system replies with “User is busy or unavailable”

My setup:

  • I am NATed
  • I have no firewall active on the server; it is a development system.
  • I have no Port Forwards on the router; I thought with the connections being originated from inside the LAN, like my existing system, (PBXiaf), I did not need Port Forwards.

If you have any ideas on how to get past this, I’d sure appreciate your input. Then I can finish the configuration and share my documentation.


@sduthil , I am still getting used to the etiquite of forums, but I thought about this after-the-fact and thought it would be impolite to refer to someone in a post but not tag them so, after my original Reply, I included your tag in the previous post on this topic, where I referred to the interaction you and I have had but I do not know if an edit properly catches the tag so am letting you know via this seperate post that I referred to you in the post at (ie this topic)

Sorry for not thinking of that sooner.

Solved. See