Unable to connect SIP client

Hi there,
I am trying to configure Wazo in a local test environment to try it out first.
I followed this guide: https://sparrow.b5.pm/docs/quick-start/
I have:
added contexts, created a user, created a corresponding line for the user.
However I am unable to connect my SIP Softphone (microSip).
It always throws the “Incorrect Password” error.
I have tried the following username/password combinations:

  • User Mail / User Password
  • User Name / User Password
  • Line Name / Line Password
  • Line Provisioning extension / Line Password
  • Line Name / User Password
  • User Name / Line Password
  • Line number / Line Password
  • Line number / User Password

However all of these fail.
If I have missed anything, or you need more info don’t hesitate to ask!
any help is appreciated!

(Yes I have looked through the similar forum posts)


if you use a Sip client, you have to use the line credentials:

go to “user Management / lines” and select your line.
click the edit button

then, go to authentificatoin tab

You will find the username and password for the line.

I don’t know microsip

depends on the application, you need to give the correct information.

i found it:

sip server: ip or hostname of your wazo-platform server
sip proxy: empty if you have none
username: the username of your sip line
domain: ip or hostname of your wazo-platform server
password: the password of your sip line

is it works for you ?


1 Like

thank you for your answer!
unfortunately that didn’t work:

The Server is reachable (when it’s not started, I get a “Bad Gateway” error after ~10 seconds, but this throws a “Bad Password” error immediately)


just tested.

domain need to be a public domain name, like: mywazo.mycompagny.com

if you are just testing wazo in a local environnement, you should try an other sip client.

jitsi, or linphone are able to connect without domain name.

also, you can try my demo app, but it’s not finished yet, and not for production use (token expire after 1 hour):


for this demo app, you need to connect with the user credential (not the line one).

also, wazo-platform have a demo app (as a starter for developpers), allowing you to make a call:


I do not know if this is still the case or not, but when I configured Wazo to use SoftPhones, I had to make sure the Line Name used for teh SoftPhone was all number, not AlphaNumeric and no Special characters

Thanks for the answers, but I still don’t get it to work.
I am using Jitsi, and entering the following information:

and still getting wrong password error:

weird things.

it works with my VM server, no configuration.



in your case, you use username@wazo
but, when you try “ping wazo”, do you ping your Wazo server ?
maybe prefer the ip address

so, should be 100@x.x.x.x

tested on my server:
working with IP
wrong password with hostname.domain


I just tried it again with the IP.
Old Line, and created a new User with a corresponding line, still the same issue:

Do you have a proxy between your computer and your wazo server ?

fritz.box seems to be your router.

you should have a look about opening specific port, like 5060.

At first, the issue does not seems to be an issue from Wazo Platform, but in your network.

also, udp should be enabled.


It’s all local (same subnet, no router, firewall or proxy in between)
I can reach the server with pings, HTTP, and SIP as well since it responds with “wrong password” instead of “unreachable” which happens when the Server is shut down.

if there are any log files I can share I would be more than happy to!

edit: just did a Portscan on the VM, these are the open ports:

Maybe fail2ban is activated because you did mistake at the beginning for the authentication. Stop it and retry.

It was started, I shut it down, still nothing.

I also looked at iptables if there were any rules there, but all were set to accept all traffic

Can you show us a result of your registration in the Asterisk cli.

$ asterisk -r

Can you also check with sngrep the register packet?

Thank you.

That was the final hint…
Checked with asterisk -r and the following message popped up:

[2024-04-02 12:45:47.6273] WARNING[2294]: res_pjsip_registrar.c:1282 registrar_on_rx_request: Endpoint 'hvtiaj8q' ( has no configured AORs

It turns out that I didn’t choose a SIP Template when creating the users.
I created another one (this time choosing the global config) and it worked instantly…
thank you so much @quintana and @julienfr for your help!

Now it also works with microSIP

1 Like