Keystroke / Softkey setting to send call to Parking Lot

Does anyone know what I do to send calls to the Parking Lot?

  • a sequence of keys on the dialpad?
  • a setting for a softkey?

I have a Parking Lot setup (Internal Extension: 5000 with Stots Start: 1 and Slots End: 5) and I have tried to use blind transfer (*1) to transfer the call to the Parking Lot but no go.

I looked up on Asterisk web site and it says Parking, since Asterisk 12, is no longer avaialble via extension features so I am assuming there is some custom entry required to send a call to the parking lot but I cannot find Wazo documentation for it anywhere.

I am using the Web UI if it makes a difference

Hi Ramblin,

you usually transfer the call to the parking extension using an attended transfer. At the beginning of the transfer the slot number to retrieve that call will be announced on your phone, after hearing that number you can hangup to complete the transfer.

A blind transfer key would not fit your need because you would not be able to know where the call is parked.

The Asterisk features for this is parking lot https://wiki.asterisk.org/wiki/display/AST/Asterisk+16+Application_Park which is more configurable that the feature code and allow multiple parking lots to be configured on the same Asterisk.

I understand what you are saying.

This setup is for a home office so I only allow one Slot for Parking so I always know where to go to retrieve it.

That is why I want blind transfer, so I can just press a key and walk away, without having to remember anything else.

I have the Pickup softkey sonfigured with BLF so when there is a call parked, it lets other users know.

I also use Intercom/Paging to announce there is a call parked and tell them to Pickup.

It makes it less confusing for users (including me :slight_smile: )

With my simple setup and minimal people using, it has never been an issue for me in 8 years with my existing softPBS (PBXianaflash) so I am looking to duplicate the setup.

I’ll take a look at the link you provided and see if that gives me what I need to finish it.

Thanks

I am not sure what is going on

I can transfer to the Parking lot using the txfr key on the Aastra. What that does is put the incoming line on hold and uses a new line to call the Parking lot then joins them.

But I cannot use any of the star codes to transfer calls. Not BLind Transfer (*1), not Attended Transfer (*3).

THis is true for teh Aastra phones and a Softphone.

The DTMF codes are working when I join a conference and enter the PIN so that part appears to be working.

Are there settings I am missing to activate the star-codes? I have enabled them in the Advanced settings.

In 18.13, I was required to enable a setting called DTMF transfer before paging or Parking would work with star codes.

Is there a need to do that in 20.02? If so how do I do that?

Any thoughts appreciated

Anybody know how to get Attended or Blind Transfer to work using star-codes?

I have Park and Pickup working, as long as I use the programmable softkey on my Aastra.

I cannot get Attended or Blind Transfers to work using the star-codes *2 or *1 so I am unable to Park a call from a softphone or a phone connected via an ATA, both of which I can do with my current PBX, so I am assuming I need to somehow activate in Wazo the ability to transfer using dtmf.

In Wazo 18.13 there was a setting in the features checkbox called DTMF transfer, which had to be enabled before before Parking would work with star codes. I cannot find any such setting in Wazo 20.04 and an internet search for “dtmf transfer” pointed to a “T” or “t” setting in the dialplan, but I do not know where to look or what to set to make sure that is set.

I tried setting “allowtransfer” to yes for each line but that did not help and I see that “allowtransfer” is set to yes in the SIP_General settings so I do not think that is the issue.

Anybody know how to get Attended or Blind Transfer to work using star-codes?

Thank you to @pcm who provided the answer!

So, it turns out, this is an existing (and known) issue with the current (20.04) and previous versions of Wazo. See https://wazo-dev.atlassian.net/browse/WAZO-1467 for the bug report. @sduthil is working on a fix, but for now, we have a patch you can implement using the Wazo custom configuration tools which WILL survive an upgrade.

The setting to enable dtmf transfers is available if you are using the API but not with the Web GUI. If you use the API to enable dtmf transfers and then make changes with the Web GUI, you may undo the API changes, so that is not a good solution.

You can enable dtmf transfers for all users or selected users. I chose to enable it for all users, but if you want, you can do it for selected users. I will show you the patch that enables dtmf transfer for all users.

In

/etc/asterisk/extensions_extra.d

add a file name

dtmf-transfer.conf

(you can call it whatever you want as long as it ends in .conf)
In dtmf-transfer.conf add the following:

[xivo-subrgbl-user]
exten = s,1,NoOp(Adding the ability for users to transfer calls using star-codes (eg *1 and *2))
same = n,Set(XIVO_CALLOPTIONS=tT${XIVO_CALLOPTIONS})
same = n,Return()

Now go back in and set the file permissions so the configuration can be accessed by Asterisk and the Web GUI:

chown asterisk:www-data /etc/asterisk/extensions_extra.d/dtmf-transfer.conf
chmod 660 /etc/asterisk/extensions_extra.d/dtmf-transfer.conf

The only thing to be careful of is that there are no other files in /etc/asterisk/extensions_extra.d that invoke the [xivo-subrgbl-user] global subroutine. There are none in the default Wazo setup so unless you add one elsewhere, you do not have an issue. By using the [xivo-subrgbl-user] global subroutine you do not need to add anything to each user’s setting to enable dtmf transfers.

Reboot your server and all users now have the ability to transfer calls using star-codes whether they are the recipient of or originator of a call.

In the default Wazo setup, you have two transfer types you can now do with star-codes:
*1 = Blind Transfer
*2 = Attended Transfer

If you do want to have only selected users have the ability to transfer calls using star-codes, change the name of the subroutine from the global subroutine (ie does not have to be called manually) [xivo-subrgbl-user] to something else like [allow-transfer] (ie a user-defined subroutine that has to be called to be in effect) and then add this subroutine name to the subroutine field in selected user’s configuration in:
User -> General (tab) -> Subroutine (field). Leave the [] brackets out ewhen entering the subroutine name in the Subroutine field.

Thanks Pascal @pcm !

An update:

In the above examples, I added tT to the DialPlan. I do NOT now recommend this as it opens your system up to hackers. Just add t (lower case t) NOT T (upper case T).

When you add t to the DialPlan, it allows the called party to transfer the call. So for an incoming call, which is the call you would want to Park, this allows that functionality.

If you add T to the DialPlan, it would allow the calling party to transfer the call, which you do not use for the Park functionality but a hacker could use this to call your voicemail and then use the transfer function to connect to a Long-Distance connection. There MAY be times when you want T enabled, such as a remote worker called by the pre-mobility subroutine who wants to transfer the call to another extension, but that is not the scenario I face and if you do implement T, then put other safeguards around it. SInce I do not need this functionality, I disabled it for better security.

So. in directory /etc/asterisk/extensions_extra.d create a file dtmf-transfer.conf add the t (lower-case t) but NOT the T (upper-case T) as shown in the example corrected here:

[xivo-subrgbl-user]
exten = s,1,NoOp(Adding the ability for users to transfer calls using star-codes (eg *1 and *2))
same = n,Set(XIVO_CALLOPTIONS=t${XIVO_CALLOPTIONS})
same = n,Return()

and of course, set the permissions to

chown asterisk:www-data /etc/asterisk/extensions_extra.d/dtmf-transfer.conf
chmod 660 /etc/asterisk/extensions_extra.d/dtmf-transfer.conf

Then reload the Asterisk DialPlan with

asterisk -rx "diaplan reload"