Wazo Voicemail call back not available

I have a customer that wants to callback from inside the voicemail. I looked in asterisk voicemail under advanced options and option 2 is call back. Wazo does not offer option2 under advanced options and says “I am sorry I did not understand your response” when you press 2 under advanced options. I want to know how to activate call back in Wazo.


Adding Automatic Callbacks to Your Asterisk Voice Mail System. Don’t you just love those Baby Bell phone messages that say “Press 1 and, for a charge of 75¢, we will place this call for you"? Well, now you can add similar functionality to your Asterisk Voicemail System minus the 75¢ charge. Sometimes it’s a lot more convenient to have the computer do the dialing after you’ve listened to a voicemail message particularly when you’re zipping down the highway at warp speed. To add the functionality to Asterisk using the Asterisk Management Panel (AMP) or freePBX, here’s how. Open the settings for the voicemail extension you wish to configure with this option: Settings->Extensions->ext# . Now scroll down to the vm options field and add the following: callback=from-internal . Save your changes and click the big Red Bar to update Asterisk. In the future, when you listen to a voicemail message on this extension and want to automatically return the call, choose 3 for Advanced Options and then 2 to Return the Call. Just be sure your Default Asterisk Outbound Route is configured to dial using the same number format as your received CallerID numbers, and you’re all set. And, by the way, this works with Asterisk@Home versions at least as far back as 1.5. Too bad no one ever bothered to document it. Very slick!

I do not know where to put voicemail options in Wazo.

I placed callback = from-internal in global voicemail and call back is now an option in advanced options. When I select advanced options and press 2 wazo says the number to callback and asks if you want to dial this number press 1. When you press 1 the call hangs up. There must be some missing dial plan. Any help would be great.

Have you check the asterisk logs? You. probably missed the good dialplan for the routing.

I changed the callback = default and it works! Any thoughts on best security