How to create webrtc video call and audio call

how to setup webrtc configuration and make voice and video call

any one given demo or documentation

Please check Webrtc Client Demo

Dear team,

Sir i need front end configuration for webrtc.Like how to user creation ,template mapping,
Extension and context writing and device mapping and more

I need basic configuration in wazo webrtc sir

We tried simply user creation and webrtc template mapping save and exit .

Then go to wazo-webrtc-demo page
Login detaila enter successfully

Then open calling page this page show
To ask textbox for phone enter below two button are available one for audio call and video call icon button

That text box which number enter to make a call

Please give a document or demo for staring configuration


Dear team,

I am tried but its not working.
Please give other solution.


hi team,

how to configure astrisk extention and sip user
in backend

how to start backend python server and view page path

Dear Team,

while wazo installation time throw below errors,

TASK [uc-engine : Setup engine] ***********************************************************************************************************************************************************************************
fatal: [localhost]: FAILED! => {“access_control_allow_origin”: “*”, “changed”: false, “connection”: “close”, “content_length”: “37”, “content_type”: “application/json”, “date”: “Tue, 27 Jun 2023 10:18:32 GMT”, “elapsed”: 0, “json”: {“message”: “Internal Server Error”}, “msg”: “Status code was 500 and not [201]: HTTP Error 500: INTERNAL SERVER ERROR”, “redirected”: false, “server”: “nginx/1.18.0”, “status”: 500, “url”: “https://localhost:443/api/setupd/1.0/setup”}

PLAY RECAP ********************************************************************************************************************************************************************************************************
localhost : ok=119 changed=24 unreachable=0 failed=1 skipped=55 rescued=0 ignored=0

please give a solution.

Hi, which version please?

Dear team,

I am installed version is wazo 23.09

It’s not yet released. Looks like a bug in the dev version.

You can you look at the /var/log/wazo-setupd.log for the traceback and the request received
(don’t forget to hide sensitive information if you post here)

Dear Team,

please check below the log file error,

‘Connection’: ‘close’, ‘Accept-Encoding’: ‘identity’, ‘User-Agent’: ‘ansible-httpget’, ‘Content-Type’: ‘application/json’, ‘Content-Length’: ‘123’} with data {“engine_internal_address”: “localhost”, “engine_language”: “en_US”, “engine_license”: true, “engine_password”: “sysadmin”}
2023-06-27 17:45:19,808 [8857] (ERROR) (wazo-setupd): Exception on /1.0/setup [POST]
Traceback (most recent call last):
File “/usr/lib/python3/dist-packages/flask/”, line 1950, in full_dispatch_request
rv = self.dispatch_request()
File “/usr/lib/python3/dist-packages/flask/”, line 1936, in dispatch_request
return self.view_functionsrule.endpoint
File “/usr/lib/python3/dist-packages/flask_restful/”, line 468, in wrapper
resp = resource(*args, **kwargs)
File “/usr/lib/python3/dist-packages/flask/”, line 89, in view
return self.dispatch_request(*args, **kwargs)
File “/usr/lib/python3/dist-packages/flask_restful/”, line 583, in dispatch_request
resp = meth(*args, **kwargs)
File “/usr/lib/python3/dist-packages/xivo/”, line 41, in wrapper
return func(*args, **kwargs)
File “/usr/lib/python3/dist-packages/xivo/”, line 31, in wrapper
return func(*args, **kwargs)
File “/usr/lib/python3/dist-packages/wazo_setupd/plugins/setup/”, line 18, in post
File “/usr/lib/python3/dist-packages/wazo_setupd/plugins/setup/”, line 32, in setup
File “/usr/lib/python3/dist-packages/wazo_setupd/plugins/setup/”, line 80, in setup_without_nestbox
File “/usr/lib/python3/dist-packages/wazo_setupd/plugins/setup/”, line 174, in post_confd_wizard
File “/usr/lib/python3/dist-packages/wazo_confd_client/commands/”, line 13, in create
response =, body, timeout=timeout)
File “/usr/lib/python3/dist-packages/wazo_confd_client/”, line 64, in post
self.check_response(response, check_response)
File “/usr/lib/python3/dist-packages/wazo_confd_client/”, line 31, in check_response
File “/usr/lib/python3/dist-packages/requests/”, line 943, in raise_for_status
raise HTTPError(http_error_msg, response=self)
requests.exceptions.HTTPError: 500 Server Error: Unexpected error: (raised as a result of Query-invoked autoflush; consider using a session.no_autoflush block if this flush is occurring prematurely)
(psycopg2.errors.UniqueViolation) duplicate key value violates unique constraint “netiface_ifname_key”
DETAIL: Key (ifname)=(enp0s3) already exists.

[SQL: INSERT INTO netiface (ifname, hwtypeid, networktype, type, family, method, address, netmask, broadcast, gateway, mtu, vlanrawdevice, vlanid, options, description) VALUES (%(ifname)s, %(hwtypeid)s, %(networktype)s, %(type)s, %(family)s, %(method)s, %(address)s, %(netmask)s, %(broadcast)s, %(gateway)s, %(mtu)s, %(vlanrawdevice)s, %(vlanid)s, %(options)s, %(description)s) RETURNING]
[parameters: {‘ifname’: ‘enp0s3’, ‘hwtypeid’: 1, ‘networktype’: ‘voip’, ‘type’: ‘iface’, ‘family’: ‘inet’, ‘method’: ‘static’, ‘address’: ‘’, ‘netmask’: ‘’, ‘broadcast’: ‘’, ‘gateway’: ‘’, ‘mtu’: 1500, ‘vlanrawdevice’: None, ‘vlanid’: None, ‘options’: ‘’, ‘description’: ‘Wizard Configuration’}]
(Background on this error at: for url: http://localhost:9486/1.1/wizard
2023-06-27 17:45:19,848 [8857] (INFO) (wazo-setupd): response to in 1.34s: POST http://localhost:443/1.0/setup 50

Dear Team,

see this version,

root@sysadmin:/var/log# cat /usr/share/wazo/WAZO-VERSION

The timestamp doesn’t match with the one with your initial error
timestamp from ansible/install: Tue, 27 Jun 2023 10:18:32 GMT
timestamp from the log: 2023-06-27 17:45:19,808

Did you try to re-run wizard after the first 500? Because the error you show me tell us that the interface already exist. Probably because of the half configuration from the first error 500

It would help to have the matching log
Otherwise, you may try to reinstall on new instance
or use wazo-reset to remove/reset the database an execute ansible/curl separately

i want to get (in and out call voice file and meta data file )donot want compained wav file

root@wazodepian11:~# wazo-call-logs -c 100000
2023-07-04 18:01:34,667 [88407] (ERROR) (wazo_call_logd.main_sweep): undefined environment variable XIVO_UUID
2023-07-04 18:01:34,667 [88407] (CRITICAL) (root): XIVO_UUID environment variable is not set
Traceback (most recent call last):
File “/usr/bin/wazo-call-logs”, line 33, in
sys.exit(load_entry_point(‘wazo-call-logd==1.2’, ‘console_scripts’, ‘wazo-call-logs’)())
File “/usr/lib/python3/dist-packages/wazo_call_logd/”, line 46, in main
File “/usr/lib/python3/dist-packages/wazo_call_logd/”, line 71, in _generate_call_logs
set_xivo_uuid(config, logger)
File “/usr/lib/python3/dist-packages/xivo/”, line 168, in set_xivo_uuid
config[‘uuid’] = get_xivo_uuid(logger)
File “/usr/lib/python3/dist-packages/xivo/”, line 163, in get_xivo_uuid
raise UUIDNotFound()
xivo.config_helper.UUIDNotFound: XIVO_UUID environment variable is not set

hi team,
actually i am facing below error
first i am configure user after that
user select to delete and edit its throw below error from interface

how to resolve the error ?

line: Resource not found

^ Details

GET http://localhost:9486/1.1/lines/1: [“Resource Not Found - Line was not found (‘id’: 1)”]

i want voice mail configurtaion step in ui .

what is the difference butween group call and conference call

  • Group call is a group ring, you put users inside and all this user receive the incoming call. Only one people answer the call. Only audio support.
  • Conference call is to permit multiple user to discuss together, all participants are mixed in the conference, audio and video are possible.