Bug in [pre-mobility]?

In the 20.06 release of Wazo, changes were made to the examples.conf file in the /etc/asterisk/extensions_extra.d directory.

The line

n,Set(XIVO_INTERFACE={XIVO_INTERFACE}&Local/{XIVO_MOBILEPHONENUMBER}@$default)

was changed to

n,Set(XIVO_INTERFACE={XIVO_INTERFACE}&Local/{XIVO_MOBILEPHONENUMBER}@${XIVO_MAILBOX_CONTEXT})

in what I assume was an attempt to get rid of the requirement for the user to manually change the “default” if the user had changed the name of the internal context and made it something other than default.

(By the way, the comments above the line still tell the user to change “default” but there is no “default” in the code.)

I just tried the new setup and it did not work.

When I wnet back in and changed ${XIVO_MAILBOX_CONTEXT} to the name of my internal context (NOT default), it worked again.

So I have a work-around, but thought you’d want to know.

Is this the correct way to submit bug reports?

Hello @Ramblin

I opened an issue https://wazo-dev.atlassian.net/browse/WAZO-1774
I’m waiting feedbacks from Franck (the PR author)

Can you describe your scenario to reproduce the issue? (ex: create a user with or without voicemail?)

Next time you can open an issue on https://wazo-dev.atlassian.net/projects/WAZO

Thank you for report :slight_smile:

I cannot be 100% certain which user I was testing this on.

At the time I was finalizing an installation and bouncing back and forth between the development and production systems, and trying different things with the new Wazo version.

So memory of that specific issue is a little foggy.

I would be willing to guess that the user I tried this on did not have a voicemail assigned, which would explain why it did not piickup the ${XIVO_MAILBOX_CONTEXT} , but I cannot be sure and I have since deleted the test entries and finalized the system.

I know I did replace ${XIVO_MAILBOX_CONTEXT} with the actual name of the internal Context and all is working now.

Yes I confirm, if user doesn’t have voicemail then it will fail.
I will revert this change for the next release (planned for the next week)
Thanks