Trouble getting api token


I have to use wazo-confd api and need a bearer api authentification key in order to use requests. I’ve tried to follow the guidelines and get the api token I need by using a POST token request. The uuid and password are from a specific user which I’ve created using the “API key” web interface.

The token request provides me an HTML that specify “405 Not Authorized”.

I am a bit lost with process. It would realy be appreciated if any of you could give me any advice or piece of information that could be useful.

My regards,
Lucas St—


Please can you show us what you did? There is some questions around this subject in the forum, have you search in different topic here?

Hi quintana,

First of all, thank you for your answer.

I’ve used the POST request as shown in the screen. Of course, this is not my wazo url but I didn’t want to share it here so I’ve changed it.

It returns me the screen I’ll upload in a new message since I’m only allowed to link one per post.

So, to sum it up, I have to get an api key in order to use wazo-confd api. However, the only thing I could find were logs from an api related user you create from the web interface. I tried to use the POST token method which should provide me the Key but it is not working.
I’ve searched on the forum related topics but I havn’t found one which could help me in my case.

Screenshot from 2022-06-16 08-43-52

You don’t use the good endpoint. Have you check our openAPI spec?

For a token it’s a POST to https://server/api/auth/0.1/tokens

Check the documentation here:

And API console here:


Thank you for your answer. I checked links on the website, especially this link :

I will stop using postman and start using API console you linked.

I will stay in touch with you if I still don’t manage to get it working.

Well, for POST token method it returns me a “Authentification Failed” error.

I then wanted to try other requests to see if it’s a specific error for this one but when I swapped to the wazo-config console I got this with the same url I used for authentification :

Do you think the problem could come from domain name ? If so, I will see with my employer if there is anything we can do to get it working.

In the console you need to use the server IP address or domain name and get token with the format user: password in the field just after the domain. When the token is set you can play with the API console.