Hi there,
I have a asterisk server running on my machine.
I need to develop a softphone app using wazo-js-sdk
is it possible to connect to the asterisk server directly using [wazo-js-sdk] ,If possible how do I implement it ?

Hello, no you can’t, it’s has been developed to use with wazo not directly with Asterisk. If you want to develop a softphone on the top of Asterisk use sip.js or jssip.


1 Like

Hi there,
I tried to install wazo in my ubuntu machine
it throws error:
ansible-playbook -i inventories/uc-engine uc-engine.yml

PLAY [Pre-flight checks] *********************************************************************************************************************

TASK [Gathering Facts] ***********************************************************************************************************************
ok: [localhost]

TASK [preflight-checks : Assert Debian Bullseye] *********************************************************************************************
fatal: [localhost]: FAILED! => {
“assertion”: “ansible_distribution == ‘Debian’ and ansible_distribution_major_version == ‘11’”,
“changed”: false,
“evaluated_to”: false,
“msg”: “Assertion failed”

PLAY RECAP ***********************************************************************************************************************************
localhost : ok=1 changed=0 unreachable=0 failed=1 skipped=0 rescued=0 ignored=0

What should I need to do to overcome this issue?

The installation can only be performed with Debian 11, not with Ubuntu.

1 Like

Hi there,
I installed Debian 11 os and tried to install wazo in it .

While installing wazo I got some error

TASK [uc-engine : Setup engine] **********************************************************************************************************************
fatal: [localhost]: FAILED! => {“changed”: false, “elapsed”: 0, “msg”: “Status code was -1 and not [201]: Request failed: <urlopen error [Errno 111] Connection refused>”, “redirected”: false, “status”: -1, “url”: “https://localhost:443/api/setupd/1.0/setup”}

RUNNING HANDLER [wazo-certs : Restart nginx] *********************************************************************************************************

PLAY RECAP *******************************************************************************************************************************************
localhost : ok=122 changed=60 unreachable=0 failed=1 skipped=54 rescued=0 ignored=0

How do I resolve it?

As this topic is marked as solved, you should create a new one.

did you follow all steps detailled there:

be sure to have this in your file:

wazo_distribution = pelican-bullseye
wazo_distribution_upgrade = pelican-bullseye


engine_api_configure_wizard = true
engine_api_root_password = <YOUR_ROOT_PASSWORD>
api_client_name = <YOUR_API_USERNAME>
api_client_password = <YOUR_API_PASSWORD>

api_client_name can NOT be your root user !


1 Like