ARI not initialized

After upgrading from wazo 18.03 to 20.15 I got an ARI error after starting wazo-service.

journalctl -xe output
wazo-calld[3836]: 2020-11-26 11:48:49,268 [3836] (INFO) (wazo_calld.ari_): ARI is not ready yet
wazo-calld[3836]: 2020-11-26 11:48:49,269 [3836] (WARNING) (wazo_calld.ari_): ARI not initialized, retrying in 1 seconds…

Hello, looks like the Asterisk Rest Interface is not launched. Can you check the Asterisk logs?

ERROR[5921] loader.c: Error loading module ‘’, missing dependencies: res_ari, res_ari_model, res_stasis
dpkg -l:
python3-asterisk-ari 0.4.0-4.deb10 all Python library for asterisk ARI interface - Python 3

Manualy loading modules:

**CLI> module load
Unable to load module
Command ‘module load’ failed.
[2020-11-27 21:57:03.3972] ERROR[8326]: loader.c:281 module_load_error: Error loading module ‘’, missing dependencies: res_ari, res_ari_model, res_stasis

Looks like you have some custom modules and they don’t works.

Not all modules were loaded after startup ( only 26 ?)…( asterisk > module show)
After some research I noticed , in the wazo-confgend.log file, there was a ‘permission error’ on /var/cache/wazo-confgend/asterisk directory.
This error prevented to load all modules
I noticed that the /var/cache/wazo-confgend/asterisk directory and underlying files were owned by user/group wazo-ui.
After changing user/group to ‘wazo-confgend’ the problem was solved.
I compared the permissions between an upgraded and a fresh installed wazo.
I do not known if this has something to do with the ‘apt-get install wazo-ui’ to prevent the ’ forbidden error’ during the intermediate wazo upgrade from 18.03 to 19.12 ?
At least changing permissions solved this problem…

Very strange… Thank you for your feedback.