Upgrade from 22.13 says need to run Wizard ... HOW?

I just tried to run

wazo-upgrade -d

from the CLI of my wazo installation (as root)

The download part worked just fine, but when I tried to run the actual upgrade, I got the message back

ERROR: You must configure Wazo by running the wizard (POST /api/confd/1.1/wizard) before using wazo-upgrade

I am not sure how to follow these instructions and I do not know why I am being asked to do this.
This Wazo installation has been working since 18.03 and continuously upgraded (until now) with

wazo-upgrade -d

I am on Debian 10 running as a virtual instance under Proxmox (v 6.4). Wazo (version 22.13) is the only application on this instance.
I have root access.

I saw only one other post on the forums with this Error message

but it seems to be assoicated with a recent installation of the LetsEncrypt certificate which I have NOT done and, when I see a quote from Sylvain ( @quintana ) saying

Wow, your solution scares me! This is clearly not normal.

I am NOT tempted to follow that solution. And the original author of that post came back later to say his solution did not solve all his problems.

I did try running, from my browser

https://{IP address of Wazo server}:443/api/confd/1.1/wizard

but that just sat there with the message:

fetching resource list: https://{IP address of Wazo server}:443/api/confd/1.1/wizard; Please wait.

Can someone give me guidance on what I need to do?
Please be specific; I do not usually work with APIs. I usually do everything via the Wazo GUI.

Cancel that last request for help

I rebooted the server and tried again to install the upgrade - using the same command sequence

wazo-upgrade -d

and all went well.
No idea what that was all about but panic has been averted :slight_smile:

One thing that I am not sure about:
The forums say Wazo upgrade to 22.15 was in October
My system upgraded to 22.15

But there is also a post about 22.16 - with a change to Python v3 being the big item in that upgrade - but my system did NOT upgrade to 22.16. For now, I will assume all is well but if this is an issue, could someone please clarify?


Not sure you refer to which post?
But 22.16 has been released 28 Nov (and you did your upgrade 27 Nov). You can retry and you will get 22.16