Trunck sip Openip

Bonjour.

Auriez vous un exemple de configuration d’un trunck Sip Openip.

J’ai suivis la configuration de la doc du site, j’ai des coups de main du tcyat mais j’ai toujours un soucis d’appel entrants avec l’erreur 401.

Auriez vous une idée ou des informations ?

Merci.

As tu mis un insecure invite sur ton trunk pour ne pas demander l’authentification sur ton appel entrant ?

J’ai suivis cette procédure : https://support.wazo.io/hc/en-us/articles/360030860071-Add-Configure-OPENIP-Trunk-

Voici mes paramétrés :

image


Sur cette photo, en bleu, c’est l’adresse IP coté WAN de ma connexion du bureau.

Bonjour.
J’ai toujours le soucis.
Auriez vous une idée s’il vous plait?
Merci.

Bonjour,
Je viens d’appeler OpenIP. Lors d’un appel entrant, ils reçoivent un “Invite” alors, que j’ai bien mis dans les “options” du trunck “Option Key : insecure / Option Value : invite”.

Seriez vous si il y a autre chose à faire?
Merci.
Nicolas

Le plus simple pour debugger du SIP reste d’utiliser la commande sngrep. Tu verras ce qu’il se passe concrètement. Comme ça c’est pas vraiment simple à te répondre.

Merci de ta réponse.
Que je fais un “sngrep”, j’ai aucune trame lors d’un appel entrant. mais, voici ce que j’ai dans Wireshark :
J’ai changé ne numéro de mon portable 06… par comment il apparait “6XXXXXXXX” et idem de mon numéro de test du trunck en 09 qui apparait en “9XXXXXXXX”.

Merci.

¹EúÈ|&dc·SE[rÌ(^WØÀ¨ZÄÄGNINVITE sip:9XXXXXXXX@192.168.1.90:5060 SIP/2.0
Via: SIP/2.0/UDP 94.143.87.216:5060;branch=z9hG4bK35cbi90028jqb8o3bhu0.1
P-Asserted-Identity: <sip:6XXXXXXXX@BC00.QZ02.ORANGE-MSS.FR>
From: <sip:6XXXXXXXX@BC00.QZ02.ORANGE-MSS.FR>;tag=SDe674d02-15093045049021
To: <sip:9XXXXXXXX@192.168.1.90:5060>
Max-Forwards: 62
Call-ID: SDe674d02-849a4c114294635fc0253f01b9cf0a29-v300g00020
CSeq: 550415617 INVITE
Accept: application/sdp
P-Early-Media: supported
P-Access-Network-Info: GTSN;operator-specific-GI="615600000";network-provided
Content-Type: application/sdp
Contact: <sip:6XXXXXXXX@94.143.87.216:5060;transport=udp>
Content-Length: 320
Supported: histinfo,timer
Allow: INVITE, ACK, BYE, CANCEL, OPTIONS
Session-Expires: 1800; refresher=uac
Min-SE: 90

v=0
o=- 2879664687 2231657 IN IP4 94.143.87.216
s=-
c=IN IP4 94.143.87.216
t=0 0
a=sendrecv
m=audio 39286 RTP/AVP 8 18 96 0
c=IN IP4 94.143.87.216
a=rtpmap:8 PCMA/8000
a=fmtp:18 annexb=no
a=rtpmap:18 G729/8000
a=rtpmap:96 telephone-event/8000
a=fmtp:96 0-15
a=rtpmap:0 PCMU/8000
a=maxptime:40
a=ptime:20

=================================
|&dc·S
¹EúÈEDÑ@@î²À¨Z^WØÄÄ0qSIP/2.0 401 Unauthorized
Via: SIP/2.0/UDP 94.143.87.216:5060;rport=5060;received=94.143.87.216;branch=z9hG4bK35cbi90028jqb8o3bhu0.1
Call-ID: SDe674d02-849a4c114294635fc0253f01b9cf0a29-v300g00020
From: <sip:6XXXXXXXX@BC00.QZ02.ORANGE-MSS.FR>;tag=SDe674d02-15093045049021
To: <sip:9XXXXXXXX@192.168.1.90>;tag=z9hG4bK35cbi90028jqb8o3bhu0.1
CSeq: 550415617 INVITE
WWW-Authenticate: Digest realm="asterisk",nonce="1582807647/94288fff42284e33f9c1509c7f995a62",opaque="007be5c161af0aec",algorithm=md5,qop="auth"
Server: Wazo PBX
Content-Length:  0

=================================

¹EúÈ|&dc·SE¤rÎß^WØÀ¨ZÄÄÊACK sip:9XXXXXXXX@192.168.1.90:5060 SIP/2.0
Via: SIP/2.0/UDP 94.143.87.216:5060;branch=z9hG4bK35cbi90028jqb8o3bhu0.1
CSeq: 550415617 ACK
From: <sip:6XXXXXXXX@BC00.QZ02.ORANGE-MSS.FR>;tag=SDe674d02-15093045049021
To: <sip:9XXXXXXXX@192.168.1.90:5060>;tag=z9hG4bK35cbi90028jqb8o3bhu0.1
Max-Forwards: 62
Call-ID: SDe674d02-849a4c114294635fc0253f01b9cf0a29-v300g00020
Content-Length: 0

Bonjour.
personne n’aurais un idée de ce que je pourrais faire ?

Merci

salut,
Concernant ton erreur SIP 401 Unauthorized, OPENIP ne fait-il pas de filtrage sur l’adresse IP ? Dans ce cas dans le portail OPENIP, essaye de renseigner l’IP publique de ton routeur.
Je sais que SEWAN par exemple font ce genre de filtrage.

1 Like

Bonjour,

Je reviens vers vous,
Voici ce que me dit un sngrep :

Auriez vous des idées s’il vous plait?
Merci.

J’ai toujours un soucis d’appel entrant : Voici ce que j’ai :

il semble que tu as un soucis d’invite qui se fait jeter (c’est bien sngrep :wink: )
as tu réglé au niveau des options de ton trunk sip l’option insecure
insecure invite par exemple

Si c’est applicable à la version Entreprise, ca doit fonctionner tout aussi bien sur Wazo Plateform