Basic call failure

We have Wazo installed on AWS instance. I triy call first time with Wazo. I created two user with extention. I am able to register them. But when I call from one extention to another, legB call is not being created. Asterisk send me 200OK to LegA side. I use “global” as template.
I can see the cdrs and their ‘answered’ field field is false.
Under /var/log I couldn’t see any log related my calls.
What can be the missing? and how can I trace them?

Here is error in my asterisk debug:

[2024-01-25 12:27:34.9845] – Executing [s@wazo-schedule-pre-dial-hooks:4] Return(“PJSIP/9qhzkz02-0000000c”, “”) in new stack
[2024-01-25 12:27:34.9845] – Executing [s@user:45] Dial(“PJSIP/9qhzkz02-0000000c”, “PJSIP/5phlpdhy,30,b(wazo-pre-dial-hooks^s^1)”) in new stack
[2024-01-25 12:27:34.9842] ERROR[70748]: res_pjsip.c:993 ast_sip_create_dialog_uac: Endpoint ‘5phlpdhy’: Could not create dialog to invalid URI ‘5phlpdhy’. Is endpoint registered and reachable?
[2024-01-25 12:27:34.9842] ERROR[70748]: chan_pjsip.c:2698 request: Failed to create outgoing session to endpoint ‘5phlpdhy’
[2024-01-25 12:27:34.9843] NOTICE[71166][C-0000000d]: app_dial.c:2719 dial_exec_full: Unable to create channel of type ‘PJSIP’ (cause 3 - No route to destination)

I use 5phlpdhy as username while registering. it is given by Wazo.

Best regards

Hello, your endpoint 5phlpdhy is not registered.

Thank you for your reply. I was registering but I noticed that my sip client was not responding OPTION message that Asterisk sends. That is why my contact was unavailable.

I was just curious, is there a way to disable it for testing purposes?

I tried to add the following lines to /etc/asterisk/pjsip.d/01-wazo.conf:



Best regards

Wazo has a SIP template system that offers these types of options. Have you tried using it?