Upgrade 18 to 20 - '403 Forbidden' Error

Upgraded from 18 to 19 and started getting a 403 Forbidden when trying to use the web interface. Upgraded again from 19 to 20 and still getting the error. After much googling have made slight changes to nginx (sites-available) but still no solution.

Please advise on where to start the troubleshooting


When you created your Wazo instance, did you edit the configuration file before running ansible installer to change the hostname to something that was accessible from the public internet?

If not (ie if you have a NATed server, you will get an error message about the certificate.

Depending on your browser, just accept the risk and proceed with the certificate that is there.

I did not edit the config file. Definitely appears to be a certificate error. Both Chrome and Safari are blocking even with I select to “proceed to the webpage anyway”.

Thanks much for the help/reply.

Would anyone be able to point me in the right direction of getting a certificate set up or repairing what I have? I’m pretty familiar with linux but this is not something I’m familiar with.

Thanks in advance.

Upgrading from version 18.03 to 20.xx, completely disables web access, so install the UI package :
apt-get install wazo-ui

Personally, I do not hook at all to this interface, I think it is still under construction, but I have a lot of trouble moving to a version 20. :neutral_face:

That did the trick! Thanks so much for the tip.

FWIW - the upgrade from 17 to 19 to 20 was effortless using a simple command line apt-get upgrade. The Debian upgrade was also pain free.

Much more so than 15 to 17 so the developers have done great work. Still getting used to the new web interface but looks much more modern and clean.

Thanks so much to all involved with WAZO.

-Shawn Chaney

1 Like

after upgrading from 16.08 to wazo 18.03 and then to wazo 20, nothing works in the web interface.
I installed the: apt-get install wazo-ui
but i have a lot of error in the interface.
I therefore advise against updating when the wazo is too old …

Continuing the discussion from Upgrade 18 to 20 - '403 Forbidden' Error:

I have 18.03 working. is there a pain free way to upgrade to 20.03 or 20.04 or do I need an intermediate step? Any help is very appreciated.

If you are a DIY type or of somewhat limited knowledge (like me) on this type of software I’d recommend sticking with 18.03. It appears as though Wazo has headed off toward proprietary direction with little support for the DIY users. As a result, the very helpful setup and support of Nerd Vittles has migrated to IncrediblePBX.

@sprint27c nope it’s wrong, wazo-platform is 100% free software.

In my case the 403 error appeared because a symlink for the nginx config has not been created. I did it manually:
sudo ln -s /etc/nginx/locations/http-available/wazo-ui /etc/nginx/locations/http-enabled/wazo-ui
sudo systemctl reload nginx
And the ui became accessible.