Lose registration when internet fails but not regain registration when internet comes back

Anyone have any ideas on how to solve an issue with trunks NOT automatically returning to registering after an outage has ben restored, even after a system reboot?

I am having an intermittent issue which is ongoing and causing issues. Does anyone have configuration suggestions (or other suggestions) that could alleviate the issue?

I am on Wazo 23.10 on a Provmox VM. My 5 trunks are all with Vitelity. I have a fixed external IP address for my location and fixed internal IP address for the NATted Wazo server in my location.

This configuraiton has been in place for over a year and normally works very well for my small home/office installation with 8 landline IP Phones and a few other softphones occasionally connected.

The problem is when I lose internet connection, which can happen about once a month. The trunks connected to Vitelity lose registration when the internet connection goes down but if the internet outage is not a quick blip (ie lasts, say, 5 minutes or more), when the interent is restored, the trunks connected to Vitelity do NOT come back. Instead, when I enquire with
asterisk -rx "pjsip show registrations"
I get back, for each of the 5 Vitelity trunks a status of rejected.

The trunks will NOT re-register by themselves and will NOT re-register even if I reboot the system.

I need to shutdown the system and wait at least 15 minutes to start the system and then all is well again.

So it sounds like a firewall/fail2ban issue but I canot figure out what firewall/fail2ban issue would cause this, especially since a temporary (15 minute) shutdown and startup restores all to normal.

To say the least, not a good scenario. And since My “users” are my wife and daughter (and my clients and our friends who call), having them unhappy is not a good thing.

Unfortunately/Fortunately, the issue intermittent and troubleshooting/testing solutions is not easy to manage so I am asking if anyone has seen a similar issue and if so, what was their solution?

My trunk registration with Vitelity is set in a Template for all trunks and includes, in the Endpoint settings:
identify_by username,auth_username,ip
I include this bit if information since I read somewhere that NOT using IP registration is a potential issue but I want to be able to differentiate which trunks are in use so would prefer to keep the identify_by setting as is but if it is causing the issue, then I will change.

I also read somewhere that if the provider sends a 403 (instead of 401) response to a lost registration this could cause the issue and in chan_sip there was a setting called
but I cannot find an equivalent in chan_pjsip nor would I know where to enter it using the Wazo GUI (which is what I use for all configurations)

So, I have exhausted my technical knowledge.

Anyone have any ideas on how to solve the issue of trunks NOT automatically returning to registering after an outage has been restored, even after a system reboot?

Can you check with sngrep? Trace is welcome for help.

Thank you for the quick reply

All trunks are currently registered and working, so when it happens again, I can use sngrep to get the connection status at that time.

Is there anything you can suggest in the meantime that might be causing the issue?

Honestly i don’t know, i don’t think it’s an issue on Asterisk, but we need to have all informations. Sometimes it’s also an issue with the firewall packet inspector.


It happened again last night and I saved the pcap file for 4 of the rejected registrations. They are al sending “OPTIONS” but not attempting to Register.

I do not know how to send to you the pcap file since the forum only allows me to upload image files. I looked at sending you a message but it looks like it has the same upload restrictions.

How can I get the pcap file to you?

P.S. I am away for two days but will reply to any instructions you provide on my return.

Just send me on my e-mail, I’ll check.


But I need your email to do that … :slight_smile:

I assume your email is NOT notifications@wazo-platform.discoursemail.com , which is the email from which forum notifications are sent

If you want to keep your email off the forum, is a PM more secure?


sylvain at wazo, you already sent me an e-mail, that why I don’t give you again ;-).

I thought I had previously sent you an email but I guess I did not store the email address when I did. I will this time. I will PM you my email address so you can send me your email address.


FYI the new PJSIP options replacing register_retry_403 are:

  • forbidden_retry_interval (in seconds, 0 by default)
  • fatal_retry_interval (in seconds, 0 by default)
1 Like


Thank you for the feeback on the replacement for

I use the Wazo GUI so have entered them both into
Menu → Call Management → Trunks
{Select Trunk and Click Edit (pencil icon)}

In my case, since I have multiple Trunks with Vitelity, I actually put the new settings into the Template for the Vitelity Trunks
Menu → Advanced → Sip Templates
{Select Template and Click Edit (pencil icon)}

The good news:
This sounds like it may be the solution

The Bad/Good news:
Bad: I have ot been able to test solutions since @quintana offered to look at my sngrep output
Good: The inability to test is because I have not had an outage with Vitelity so have not yet been able to take this further. So you may have saved Sylvain some time … :slight_smile:

Thank you again

1 Like