Installation probleme

Hello.

i have on error when i try to install Wazo.
When i type this command :
ansible-playbook -i inventories/uc-engine uc-engine.yml

I have this error :

TASK [uc-engine : Setup engine] ********************************************************************************************************************************
fatal: [localhost]: FAILED! => {"access_control_allow_origin": "*", "changed": false, "connection": "close", "content": "{\"message\": \"Sent data is invalid\", \"error_id\": \"invalid-data\", \"details\": {\"engine_password\": {\"message\": \"Not a valid string.\", \"constraint_id\": \"type\", \"constraint\": \"string\"}}, \"timestamp\": 1576757289.2541664}\n", "content_length": "214", "content_type": "application/json", "date": "Thu, 19 Dec 2019 12:08:09 GMT", "json": {"details": {"engine_password": {"constraint": "string", "constraint_id": "type", "message": "Not a valid string."}}, "error_id": "invalid-data", "message": "Sent data is invalid", "timestamp": 1576757289.2541664}, "msg": "Status code was 400 and not [201]: HTTP Error 400: BAD REQUEST", "redirected": false, "server": "nginx/1.14.2", "status": 400, "url": "https://localhost:443/api/setupd/1.0/setup"}
        to retry, use: --limit @/root/wazo-ansible/uc-engine.retry

PLAY RECAP *****************************************************************************************************************************************************
localhost                  : ok=129  changed=30   unreachable=0    failed=1

have you one idea for this?

Thank’s you.

I had the same problem when I wanted to install. Could someone have solved this problem.

Please add the log and error if you want someone help you.

I think in mattermost the solution was to use a password less complicated.

The following PR should fix the issue: https://github.com/wazo-platform/wazo-ansible/pull/57

Hello,

I no longer know where I marked it (on the Forum or on Mattermost). But where, the problem is solved by putting a complex password.

It’s good.
One more security.

Thank you for your feedback.

Have a good day.

Hello.

I have a new probléme in the end of installation :

When i type :

wazo-auth-cli token create --auth-user <api_client_name> --auth-password <api_client_password>

I Have this error :

401 Client Error: UNAUTHORIZED for url: https://localhost:9497/0.1/token

Or, when i type :

curl -k -X POST -u <api_client_name>:<api_client_password> -H ‘Content-Type: application/json’ -d ‘{“expiration”: 3600}’ https://127.0.0.1/api/auth/0.1/token

I Have this error :

{“reason”: [“Authentication Failed”], “timestamp”: [1577702677.6691139], “status_code”: 401}

Can you help me please?
Thank’s.

This question has been solved in the mattermost channel. I (try) copy paste the response

fblackburn [06:27 AM]
For wazo-auth-cli the argument is --auth-username not --auth-user

fblackburn [06:31 AM]
But if your curl command doesn’t work, then you have entered a wrong username/password. You can check the username with wazo-auth-cli user list --recurse . Otherwise you can create a wazo-auth-cli token with wazo-auth-cli token create to update your user password with API

nicolas56[10:29 AM]
Thank’s you.
I reset my installation and it’s ok.
I have one error witch cut and paste in ssh .