Blog: Wazo Platform 22.02 Released

Any feedback about Wazo Platform 22.02 is welcome!

1 Like

I had an issue with upgrading from 22.01 to 22.02 - system stopped working

After upgrading to 22.02, when I did asterisk -rx “pjsip show registrations” the response was “No objects found” and after a short while, the system stopped working

I restored my VM back to 22.01 (thank you Proxmox) and all is working again, but I would like to upgrade if I can figure out what the issue is.

@jkyawesome suggested in his Mattermost post Mattermost that the issue for his upgrade to 22.02 was the presence of an explicit disallow setting in his SIP template. I also have an explicit “disallow: all” setting (followed by allow: ulaw) in my SIP template but I am not sure if the issue @jkyawesome identified is universal for 22.02 or unique to his setup and I do not want to go though an upgrade/fail/restore again (with my pbx offline during this) unless the disallow setting is likely the issue with me too.

Can anyone advise if an explicit disallow setting needs to be deleted for 22.02?

Has anyone seen the issue where, after an update to 22.02, ’ asterisk -rx “pjsip show registrations” ’ returns ’ No objects found ’ and if so, what is the issue/fix?

Thank you to @jkyawesome

When I upgraded from Wazo v22.02 to v22.02 the system stopped working and in response to ’ asterisk -rx “pjsip show registrations” ’ I received ’ No objects found ’

I rolled back to v22.01 and all was good.

After reading @jkyawesome 's post above, I went to the Wazo GUI
Advanced → Sip Templates → Global → Endpoint
deleted the disallow: all setting
edited the allow: ulaw setting to allow: !all,ulaw

and tried the upgrade to 22.02 again.

It worked.

Thank you @jkyawesome.

In my case, I also refreshed the consul with
systemctl stop consul
rm -rf /var/lib/consul/raft/
rm -rf /var/lib/consul/serf/
rm -rf /var/lib/consul/services/
rm -rf /var/lib/consul/tmp/
rm -rf /var/lib/consul/checks/
systemctl start consul

It is probably a good idea for someone to update the 22.02 documentation to let people know about the @jkyawesome discovery

Spoke too soon

Initially worked fine after upgrade and
asterisk -rx “pjsip show registrations”
did show the trunks that were registered.

After a while, I am now back to the reply being
No objects found


  • asterisk -rx “pjsip show endpoints” DOES properly show status of all endpoints, including trunks
  • The Vitelity connections work both Inbound and outblound
  • The Unlimitel trunks allow Outbound but now Inbound

Unlimitel uses old Asterisk and has one trunk registration for both In and Out whereas Vitleity uses a more modern Asterisk and has separate trunk registration for Inbound and Outbound

I am porting all my lines away from Unlimitel, so I’ll rollback to 22.01 for now and hopefully will be OK once I have all on Vitelity and try the upgrade again.


We don’t have feedback with specific issues on pjsip currently. We probably need more information (logs) to understand your issue.


Thanks Sylvain

I am not sure what is going on, but the fact that my Vitelity connections are working (although not showing up in show registrations) and my Unlimitel are only working Outbound, tells me it might be an Unlimitel issue.

I would not be surprised if it was an Unlimitel issue, which is why I am porting everything to Vitelity.

So I’ll wait until the porting is complete, try the upgrade then, and if all works, we are good. If not, I’ll re-start this thread.


Yes please and give me logs. Ping me on mattermost to exchange on the issue if you reproduce it.
Thank you.

Well, I thought I was in good shape, but that just goes to show where thinking gets me.

Same issue after upgrading to Wazo v22.03

I have all the trunks ported to Vitelity and I upgraded to Wazo 22.03 (skipping 22.02), which comes with Asterisk 18.10 and I saw in the Asterisk upgrade notes that 18.10 fixed an issue with outbound registration so I was hoping …

But no

After upgrading to Wazo 22.03, it loked like all was working. The trunks were registering and all showed up with
asterisk -rx “pjsip show registrations”

I rebooted the server to give it a fresh start and when it came back to life the
asterisk -rx “pjsip show registrations”
command came back with “No objects found”

I do not think it was an issue with the reboot since the same thing happened when I upgraded to Wazo 22.02. It worked for a short while but then same as above (with no rebooting).

I have restored to Wazo v22.01 and all is well again.

I’ll ping you on Mattermost tomorrow.

I’ll have to wait until eveneing to try it again but if you can tell me what log files you want for trouble shooting, I get them for you.

Thank you for your reply.

A big thank-you to Sylvain who figured it out.

I needed to add the parameter
line = yes
to the Registration of the Inbound trunks

Apparently a new requirement for my kind of configuration

All is now working