# \[Résolu\] - Schedule en erreur de 18.03 vers 19.12

**URL:** <https://wazo-platform.discourse.group/t/resolu-schedule-en-erreur-de-18-03-vers-19-12/395>\
**Category:** Installation/Configuration\
**Created:** [May 22, 2020, 2:04pm UTC](https://wazo-platform.discourse.group/t/resolu-schedule-en-erreur-de-18-03-vers-19-12/395 "2020-05-22T14:04:56Z")\
**Posts on this page:** 1\
**Showing post:** 3

<div class="post-metadata">

**Author:** ![ymolinet](https://avatars.discourse-cdn.com/v4/letter/y/c89c15/32.png) [@ymolinet](https://wazo-platform.discourse.group/u/ymolinet)\
**Post date:** [May 22, 2020, 7:45pm UTC](https://wazo-platform.discourse.group/t/resolu-schedule-en-erreur-de-18-03-vers-19-12/395/3 "2020-05-22T19:45:11Z")

</div>

Concernant le bug cité, j’applique les informations fournies ici [Upgrade 18.03 to 19.1x (pelican-stretch) - #11 by SIP-Online](https://wazo-platform.discourse.group/t/upgrade-18-03-to-19-1x-pelican-stretch/223/11) pour corriger le problème du mot de passe dans **wazo-auth-cli** qui n’est pas stocké dans le backup.

Voici mon script de restauration de mes bases de données:

> #!/bin/bash
> 
> wazo-service stop
> 
> tar xvfp /root/backups/wazo-data-backup-18.03.tgz -C /  
> tar xvf /root/backups/wazo-db-backup-18.03.tgz -C /var/tmp  
> cd /var/tmp/pg-backup  
> sudo -u postgres psql -c ‘ALTER DATABASE asterisk RENAME TO asterisk\_previous’  
> sudo -u postgres pg\_restore -C -d postgres asterisk-\*.dump  
> sudo -u postgres pg\_dump -c -t dhcp -t netiface -t resolvconf asterisk\_previous | sudo -u postgres psql asterisk  
> xivo-update-keys  
> source /etc/profile.d/xivo\_uuid.sh  
> systemctl set-environment XIVO\_UUID=$XIVO\_UUID  
> systemctl daemon-reload
> 
> dpkg --purge --force-all wazo-auth  
> rm -r ~/.config/wazo-auth-cli  
> sudo -u postgres psql -d asterisk -c “DELETE FROM public.auth\_user WHERE username = ‘wazo-auth-cli’;”  
> apt-get install wazo-auth
> 
> wazo-service start

Je viens de regarder la table schedule et tester les URL en passant les id.  
Il y a trois entrées dans la table, et c’est seulement l’id 1 qui pose problème.  
En voulant la supprimer, je vois qu’il y a une clé étrangère vers schedule\_path, ce qui m’a permis de voir que le schedule est utilisé par un utilisateur, un groupe, et une file d’attente.  
Par rapport à ceux qui fonctionnent, je ne vois pas d’incohérence (caractère spéciaux par exemple)

Pour les schedules que je peux éditer, j’ai constaté que la référence vers les fichiers audio n’était pas maintenu dans wazo-ui alors qu’ils apparaissent dans la base. Je me demande si la table n’aurait pas loupé un upgrade.

Je préférais que l’on trouve la solution pour corriger au cas où cela se produise durant les updates de mes instances de production.

Merci,  
Yannick

---

_[View the full topic](https://wazo-platform.discourse.group/t/resolu-schedule-en-erreur-de-18-03-vers-19-12/395)._
